const regex = /(\s{3})([a-zA_Z0-9]*)(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s{3})([a-zA_Z0-9]*)(\\s{2})(\\[)([a-zA_Z0-9]*)(\\])(\\s{2})', 'g')
const str = ` 1 2 3 4 5 6 7 8 [9]
[REPLACEALL](\\s{3})([a-zA_Z0-9]*)(\\s{2})(\\[)([a-zA_Z0-9]*)(\\])(\\s{2})[WITH]\$3\$4\$2\$6\$3\$5\$1`;
const subst = `$3$4$2$6$3$5$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);