$re = '/(\s{3})([a-zA_Z0-9]*)(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})/';
$str = ' 1 2 3 4 5 6 7 8 [9]
[REPLACEALL](\\s{3})([a-zA_Z0-9]*)(\\s{2})(\\[)([a-zA_Z0-9]*)(\\])(\\s{2})[WITH]$3$4$2$6$3$5$1';
$subst = "$3$4$2$6$3$5$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;