package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.* ? J .*)`)
var str = `J00*
J01*
J02*
J03*
J04*
J05*
J06*
J07*
J08*
J09*
J10*
J11*
J12*
J13*
J14*
J15*
J16*
J17*
J18*
J19*
J20*
J21*
J22*`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}