// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.* ? J .*)").unwrap();
let string = "J00*
J01*
J02*
J03*
J04*
J05*
J06*
J07*
J08*
J09*
J10*
J11*
J12*
J13*
J14*
J15*
J16*
J17*
J18*
J19*
J20*
J21*
J22*";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}