import Foundation
let pattern = #"(.* ? J .*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
J00*
J01*
J02*
J03*
J04*
J05*
J06*
J07*
J08*
J09*
J10*
J11*
J12*
J13*
J14*
J15*
J16*
J17*
J18*
J19*
J20*
J21*
J22*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}