import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.* ? J .*)";
final String string = "J00*\n"
+ "J01*\n"
+ "J02*\n"
+ "J03*\n"
+ "J04*\n"
+ "J05*\n"
+ "J06*\n"
+ "J07*\n"
+ "J08*\n"
+ "J09*\n"
+ "J10*\n"
+ "J11*\n"
+ "J12*\n"
+ "J13*\n"
+ "J14*\n"
+ "J15*\n"
+ "J16*\n"
+ "J17*\n"
+ "J18*\n"
+ "J19*\n"
+ "J20*\n"
+ "J21*\n"
+ "J22*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}