$re = '/(.* ? J .*)/';
$str = 'J00*
J01*
J02*
J03*
J04*
J05*
J06*
J07*
J08*
J09*
J10*
J11*
J12*
J13*
J14*
J15*
J16*
J17*
J18*
J19*
J20*
J21*
J22*';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);