const regex = new RegExp('(.* ? J .*)', '')
const str = `J00*
J01*
J02*
J03*
J04*
J05*
J06*
J07*
J08*
J09*
J10*
J11*
J12*
J13*
J14*
J15*
J16*
J17*
J18*
J19*
J20*
J21*
J22*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}