import re
regex = re.compile(r"(.* ? J .*)")
test_str = ("J00*\n"
"J01*\n"
"J02*\n"
"J03*\n"
"J04*\n"
"J05*\n"
"J06*\n"
"J07*\n"
"J08*\n"
"J09*\n"
"J10*\n"
"J11*\n"
"J12*\n"
"J13*\n"
"J14*\n"
"J15*\n"
"J16*\n"
"J17*\n"
"J18*\n"
"J19*\n"
"J20*\n"
"J21*\n"
"J22*")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")