#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/?(?:[^"'\/]+\/)+[^"'\s]+?\.(?:(?:pn|jpe?)g|gif)+\b"
Local $sString = "$img1 = "foo/bar.png";" & @CRLF & _
"$img2 = 'foo/bar.jpg';" & @CRLF & _
"$img3 = "{'myimg':'foo/bar.png'}";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")