re = /\/?(?:[^"'\/]+\/)+[^"'\s]+?\.(?:(?:pn|jpe?)g|gif)+\b/m
str = '$img1 = "foo/bar.png";
$img2 = \'foo/bar.jpg\';
$img3 = "{\'myimg\':\'foo/bar.png\'}";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end