using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/?(?:[^""'\/]+\/)+[^""'\s]+?\.(?:(?:pn|jpe?)g|gif)+\b";
string input = @"$img1 = ""foo/bar.png"";
$img2 = 'foo/bar.jpg';
$img3 = ""{'myimg':'foo/bar.png'}"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}