// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\/?(?:[^"'\/]+\/)+[^"'\s]+?\.(?:(?:pn|jpe?)g|gif)+\b"#).unwrap();
let string = "$img1 = \"foo/bar.png\";
$img2 = 'foo/bar.jpg';
$img3 = \"{'myimg':'foo/bar.png'}\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}