$re = '/\/?(?:[^"\'\/]+\/)+[^"\'\s]+?\.(?:(?:pn|jpe?)g|gif)+\b/m';
$str = '$img1 = "foo/bar.png";
$img2 = \'foo/bar.jpg\';
$img3 = "{\'myimg\':\'foo/bar.png\'}";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);