import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/?(?:[^\"'\\/]+\\/)+[^\"'\\s]+?\\.(?:(?:pn|jpe?)g|gif)+\\b";
final String string = "$img1 = \"foo/bar.png\";\n"
+ "$img2 = 'foo/bar.jpg';\n"
+ "$img3 = \"{'myimg':'foo/bar.png'}\";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}