const regex = /\/?(?:[^"'\/]+\/)+[^"'\s]+?\.(?:(?:pn|jpe?)g|gif)+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/?(?:[^"\'\\\/]+\\\/)+[^"\'\\s]+?\\.(?:(?:pn|jpe?)g|gif)+\\b', 'gm')
const str = `\$img1 = "foo/bar.png";
\$img2 = 'foo/bar.jpg';
\$img3 = "{'myimg':'foo/bar.png'}";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}