package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)interface(\s[\w\d\/.]+)(.*)?`)
var str = `interface eth1/10.404 p2p
interface ae0.100 p2p
interface pool0 multibind lastresort
interface loop0 loopback
interface ae0.100
interface loop0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}