use strict;
my $str = 'interface eth1/10.404 p2p
interface ae0.100 p2p
interface pool0 multibind lastresort
interface loop0 loopback
interface ae0.100
interface loop0';
my $regex = qr/interface(\s[\w\d\/.]+)(.*)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}