import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "interface(\\s[\\w\\d\\/.]+)(.*)?";
final String string = "interface eth1/10.404 p2p \n"
+ "interface ae0.100 p2p\n"
+ "interface pool0 multibind lastresort\n"
+ "interface loop0 loopback\n"
+ "interface ae0.100\n"
+ "interface loop0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}