const regex = /interface(\s[\w\d\/.]+)(.*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('interface(\\s[\\w\\d\\\/.]+)(.*)?', 'gm')
const str = `interface eth1/10.404 p2p
interface ae0.100 p2p
interface pool0 multibind lastresort
interface loop0 loopback
interface ae0.100
interface loop0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}