// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)interface(\s[\w\d\/.]+)(.*)?").unwrap();
let string = "interface eth1/10.404 p2p
interface ae0.100 p2p
interface pool0 multibind lastresort
interface loop0 loopback
interface ae0.100
interface loop0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}