# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\d+\.?\d*) ([a-zA-Z]) \*)(.*?)(((\d+\.?\d*) \3 \*))/$3 $2 $6 + * $4/g;t' <<< "2 x * 3 y * + 3 x * + 4 y * + 3 x * +"