import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d+\\.?\\d*) ([a-zA-Z]) \\*)(.*?)(((\\d+\\.?\\d*) \\3 \\*))";
final String string = "2 x * 3 y * + 3 x * + 4 y * + 3 x * +";
final String subst = "$3 $2 $6 + * $4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}