re = /((\d+\.?\d*) ([a-zA-Z]) \*)(.*?)(((\d+\.?\d*) \3 \*))/
str = '2 x * 3 y * + 3 x * + 4 y * + 3 x * +'
subst = '$3 $2 $6 + * $4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result