import re
regex = re.compile(r"((\d+\.?\d*) ([a-zA-Z]) \*)(.*?)(((\d+\.?\d*) \3 \*))")
test_str = "2 x * 3 y * + 3 x * + 4 y * + 3 x * +"
subst = "$3 $2 $6 + * $4"
result = regex.sub(subst, test_str)
if result:
print(result)