#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((\d+\.?\d*) ([a-zA-Z]) \*)(.*?)(((\d+\.?\d*) \3 \*))"
Local $sString = "2 x * 3 y * + 3 x * + 4 y * + 3 x * +"
Local $sSubst = "$3 $2 $6 + * $4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)