#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((?=\b(?:[a-df-z0-9_]*e[a-df-z0-9_]*){2}\b)(?=\b(?:[b-z0-9_]*a[b-z0-9_]*){1,3}\b).+)"
Local $sString = "a eea" & @CRLF & _
"oe" & @CRLF & _
"eeae" & @CRLF & _
"alargedonkey" & @CRLF & _
"thebiggestmushroom" & @CRLF & _
"cheese" & @CRLF & _
"acheese" & @CRLF & _
"cheesy" & @CRLF & _
"cheesybread" & @CRLF & _
"cheesyapp" & @CRLF & _
"alphabetchocolate" & @CRLF & _
"alphabetonaplate" & @CRLF & _
"ayellowalphabetonaplate"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")