$re = '/((?=\b(?:[a-df-z0-9_]*e[a-df-z0-9_]*){2}\b)(?=\b(?:[b-z0-9_]*a[b-z0-9_]*){1,3}\b).+)/i';
$str = 'a eea
oe
eeae
alargedonkey
thebiggestmushroom
cheese
acheese
cheesy
cheesybread
cheesyapp
alphabetchocolate
alphabetonaplate
ayellowalphabetonaplate';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);