const regex = /((?=\b(?:[a-df-z0-9_]*e[a-df-z0-9_]*){2}\b)(?=\b(?:[b-z0-9_]*a[b-z0-9_]*){1,3}\b).+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?=\\b(?:[a-df-z0-9_]*e[a-df-z0-9_]*){2}\\b)(?=\\b(?:[b-z0-9_]*a[b-z0-9_]*){1,3}\\b).+)', 'gi')
const str = `a eea
oe
eeae
alargedonkey
thebiggestmushroom
cheese
acheese
cheesy
cheesybread
cheesyapp
alphabetchocolate
alphabetonaplate
ayellowalphabetonaplate`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}