using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?=\b(?:[a-df-z0-9_]*e[a-df-z0-9_]*){2}\b)(?=\b(?:[b-z0-9_]*a[b-z0-9_]*){1,3}\b).+)";
string input = @"a eea
oe
eeae
alargedonkey
thebiggestmushroom
cheese
acheese
cheesy
cheesybread
cheesyapp
alphabetchocolate
alphabetonaplate
ayellowalphabetonaplate";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}