import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?=\\b(?:[a-df-z0-9_]*e[a-df-z0-9_]*){2}\\b)(?=\\b(?:[b-z0-9_]*a[b-z0-9_]*){1,3}\\b).+)";
final String string = "a eea\n"
+ "oe\n"
+ "eeae\n"
+ "alargedonkey\n"
+ "thebiggestmushroom\n"
+ "cheese\n"
+ "acheese\n"
+ "cheesy\n"
+ "cheesybread\n"
+ "cheesyapp\n"
+ "alphabetchocolate\n"
+ "alphabetonaplate\n"
+ "ayellowalphabetonaplate";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}