use strict;
my $str = 'a eea
oe
eeae
alargedonkey
thebiggestmushroom
cheese
acheese
cheesy
cheesybread
cheesyapp
alphabetchocolate
alphabetonaplate
ayellowalphabetonaplate';
my $regex = qr/((?=\b(?:[a-df-z0-9_]*e[a-df-z0-9_]*){2}\b)(?=\b(?:[b-z0-9_]*a[b-z0-9_]*){1,3}\b).+)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}