#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d+\.\s*(.*?)\s*\(.*?\)"
Local $sString = "Y:\NetApp\S6\S16\S13\FN{10A4D962-0000-C819-870A-BF9F8837732A}{CD07E415-70D2-4BAE-B473-9F58BE06107A}-0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")