const regex = /\d+\.\s*(.*?)\s*\(.*?\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\.\\s*(.*?)\\s*\\(.*?\\)', 'g')
const str = `Y:\\NetApp\\S6\\S16\\S13\\FN{10A4D962-0000-C819-870A-BF9F8837732A}{CD07E415-70D2-4BAE-B473-9F58BE06107A}-0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}