package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\.\s*(.*?)\s*\(.*?\)`)
var str = `Y:\NetApp\S6\S16\S13\FN{10A4D962-0000-C819-870A-BF9F8837732A}{CD07E415-70D2-4BAE-B473-9F58BE06107A}-0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}