using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\.\s*(.*?)\s*\(.*?\)";
string input = @"Y:\NetApp\S6\S16\S13\FN{10A4D962-0000-C819-870A-BF9F8837732A}{CD07E415-70D2-4BAE-B473-9F58BE06107A}-0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}