import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\.\\s*(.*?)\\s*\\(.*?\\)";
final String string = "Y:\\NetApp\\S6\\S16\\S13\\FN{10A4D962-0000-C819-870A-BF9F8837732A}{CD07E415-70D2-4BAE-B473-9F58BE06107A}-0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}