re = /\d+\.\s*(.*?)\s*\(.*?\)/
str = 'Y:\\NetApp\\S6\\S16\\S13\\FN{10A4D962-0000-C819-870A-BF9F8837732A}{CD07E415-70D2-4BAE-B473-9F58BE06107A}-0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end