use strict;
my $str = 'Y:\\NetApp\\S6\\S16\\S13\\FN{10A4D962-0000-C819-870A-BF9F8837732A}{CD07E415-70D2-4BAE-B473-9F58BE06107A}-0';
my $regex = qr/\d+\.\s*(.*?)\s*\(.*?\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}