# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z]).*?(\d+?_).*?([A-Z])/$1$2$3/;t' <<< "TOWER 2_3_C"