using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]).*?(\d+?_).*?([A-Z])";
string substitution = @"$1$2$3";
string input = @"TOWER 2_3_C";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}