re = /([A-Z]).*?(\d+?_).*?([A-Z])/
str = 'TOWER 2_3_C'
subst = '$1$2$3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result