const regex = /([A-Z]).*?(\d+?_).*?([A-Z])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]).*?(\\d+?_).*?([A-Z])', '')
const str = `TOWER 2_3_C`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);