$re = '/([A-Z]).*?(\d+?_).*?([A-Z])/';
$str = 'TOWER 2_3_C';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;