use strict;
my $str = 'TOWER 2_3_C';
my $regex = qr/([A-Z]).*?(\d+?_).*?([A-Z])/p;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";