// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z]).*?(\d+?_).*?([A-Z])").unwrap();
let string = "TOWER 2_3_C";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}