package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\[id(\d*)\|([а-яА-Яa-zA-ZЁёЙй]*)\]`)
var str = `Пока телефон недоступен для брони, бронируйте в комментариях (мы свяжемся, гарантируем!) или пишите одной из двух очаровательных девушек — [id1554935|Полине] и [id811817|Наташе]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}