re = /\[id(\d*)\|([а-яА-Яa-zA-ZЁёЙй]*)\]/mi
str = 'Пока телефон недоступен для брони, бронируйте в комментариях (мы свяжемся, гарантируем!) или пишите одной из двух очаровательных девушек — [id1554935|Полине] и [id811817|Наташе]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end