import re
regex = re.compile(r"\[id(\d*)\|([а-яА-Яa-zA-ZЁёЙй]*)\]", flags=re.MULTILINE | re.IGNORECASE)
test_str = "Пока телефон недоступен для брони, бронируйте в комментариях (мы свяжемся, гарантируем!) или пишите одной из двух очаровательных девушек — [id1554935|Полине] и [id811817|Наташе]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")