$re = '/\[id(\d*)\|([а-яА-Яa-zA-ZЁёЙй]*)\]/mi';
$str = 'Пока телефон недоступен для брони, бронируйте в комментариях (мы свяжемся, гарантируем!) или пишите одной из двух очаровательных девушек — [id1554935|Полине] и [id811817|Наташе]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);